Pull request building by build.ros.org is currently not working
Incident Report for ROS
Resolved
Pull request building and commit status notification are back to normal. Retesting for pull requests updated during the incident has been triggered.
Posted about 2 years ago. Jul 17, 2017 - 21:17 UTC
Monitoring
After a Jenkins restart the new credentials are being used. We are now tracking down pull requests that did not receive updates and retesting them.
Posted about 2 years ago. Jul 17, 2017 - 20:53 UTC
Update
The revoked credential was a GitHub access token rather than an ssh key.
Posted about 2 years ago. Jul 17, 2017 - 18:47 UTC
Identified
We identified the problem as an accidentally revoked SSH key from the pull request builder account on Friday. We replaced the key, but now we're getting 401's from GitHub's API. We're still investigating why.
Posted about 2 years ago. Jul 17, 2017 - 18:41 UTC
Investigating
Pull request building from build.ros.org is down. We're debugging now.
Posted about 2 years ago. Jul 17, 2017 - 18:32 UTC